• Bluetooth Connectivity/Pairing Problems on Late 2008 MacBook Pro

    I’ve noticed that my late 2008 MacBook Pro seems to have trouble pairing with my Apple Bluetooth keyboard and Mighty Mouse occasionally.

    At home, I have a 22″ flat panel connected with two video inputs: an HDMI input from my old QuickSilver G4 tower, and a DVI cable that I attach to either my work or personal laptops (the work laptop is an early 2008 MacBook Pro, while the personal one is a late 2008). As I switch between laptops, I get semi-wireless KVM since the Bluetooth simply re-pairs with whichever laptop is turned on, and I manually re-plug the DVI cable.

    I never seem to have issues reconnecting the work laptop, but my personal one has been having issues recently. Anecdotally, this started happening after I installed Vista on Boot Camp, during which time I had a hell of a time getting Vista to connect to the Bluetooth devices (it would say it was paired but then never be able to connect). After uninstalling/reinstalling the Boot Camp drivers that came on the installation disk for my MacBook Pro, the Bluetooth on Vista started working again. I don’t know if the Vista issues spawned the issues in OS X, but there it is as the only thing related to Bluetooth that has changed.

    Anyway… I noticed I was getting these messages in Console.

    3/20/09 10:42:25 PM Bluetooth Setup Assistant[1753] connection went invalid while waiting for a reply 3/20/09 10:44:31 PM Bluetooth Setup Assistant[1771] 3:Pairing failed with 'Mighty Mouse': error 0xe00002bc 3/20/09 10:45:54 PM Bluetooth Setup Assistant[1771] 3:Pairing failed with 'Mighty Mouse': error 0xe00002bc 3/20/09 10:51:04 PM kernel IOBluetoothBNEPDriver: Ethernet address 00:23:6c:a2:5e:56 

    I went ahead and reset the PRAM and everything started working again – in fact, the laptop paired to the devices before the login screen loaded, and I was able to type in my password from my Bluetooth keyboard. Woot.

    This is the second time I have had to reset the PRAM on my personal laptop since I got it in December 2008, the last issue being related toExpressCard hardware. I’m hoping the issue was just related to me Boot Camp Bluetooth woes, but who knows.

    Category: Uncategorized | Tags: